

















User Guide Neat Image plug-in for Photoshop (Mac)

4.

Filtration process overview

4.1. Overview of Neat Image filtration process

1. Prepare image Wan -

#& Photoshop File Edit Image Laver Select TTITH Analysis 30 View Window Help
e

Convert for Smart Filters

in Photoshop, open the image to be e vy
Vanishing Point... 8V
processed,;

use the Filter > Neat Image > Reduce
Noise.. menu item to open Neat Image.

R Y e LY | A IR g

2. Prepare a noise profile

You can load a pre-built one or build a

new profile on the spot.

To build a new profile: /
click the Auto Profile button;

this will automatically find, select and
analyze a featureless (noise-only)
image area

(if you see that automatic selection
includes any important image details
then move the selection to a
featureless area and click the Auto
Profile button again)

. Adjust the filter settings

switch to the Noise Filter Settings tab; *
check preview in the viewer \

adjust the filter settings to achieve
desired level of noise reduction:

- try to vary the setting:
Noise Reduction Amounts: Luminance

and observe how the preview
changes;

- adjust the Chrominance noise
reduction amount if necessary; E

/

4. When you are happy with preview results, apply the filter to the image: click the Apply button.
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4.2. Running Neat Image on a sample image

You can download a test-Kit prepared to help you start using Neat Image plug-in:
http://www.neatimage.net/files/Testkit5.zip, 250KB. Please download and unzip it to a new folder on
the hard disk. The test-kit contains a sample image: Samplelmage.jpg. This image is a part of typical
photo taken with a digital camera. The detailed information about the test image is available in the
Samplelmagelnfo.txt file.

Please go through the stages below to see how the image can be improved by Neat Image:

Stage 1. Open the sample image in Photoshop and invoke Neat Image

1. Open the sample image (Samplelmage.jpg) in Photoshop;
You will see that there is strong noise in the image, especially in the sky area (use zoom and
scroll to better see it). This is the typical noise produced by a digital camera. The task of Neat
Image is to reduce this noise.

2. Select the Filter > Neat Image > Reduce Noise.. menu in Photoshop to open Neat Image plug-in.

Stage 2. Load the sample noise profile in Neat Image plug-in

To reduce noise in the image Neat Image generally needs a noise profile describing the noise properties
of the image. For this sample image, we have prepared such a noise profile in the test-kit in advance:
SampleProfile.dnp. Using this profile, Neat Image can efficiently reduce the noise in the image.

Noise Filter Settings

1. In the Device Noise Profile tab: [ Device Noise Profile

click Load Profile | (the Load Profile button);

2. Then in the Open Device Noise Profile dialog, navigate to the folder where the noise profile has
been unzipped and select the SampleProfile.dnp file.

Now the sample noise profile is loaded and Neat Image is almost ready to filter the image. Usually, you
would adjust the filter settings at this stage. To make things easier for the first run of Neat Image, we
have prepared a sample preset with “good” settings to process the sample image.

Stage 3. Load the sample filter preset in Neat Image plug-in
&9 Device Noise Profile |[=

1. Switch to the Noise Filter Settings tab: R—— !

and click (the Load Filter Preset button) in the Filter Settings box;

2. Then in the Load Filter Preset dialog, navigate to the folder where the sample filter preset has
been unzipped and select the SamplePreset.nfp file.

Now the sample filter preset is loaded and the filter settings are adjusted to process the sample image.

Stage 4. Apply the filter to the image

1. Click in the bottom of the plug-in window and wait until the image processing is
completed. Processing may take a few seconds. After that the filtered image is displayed in
Photoshop. Notice that the noise — especially in the sky — has been significantly reduced while
the real image details have been preserved.

Please be aware that the sample noise profile and sample filter preset supplied with the test-kit are
suitable only for images taken with that particular digital camera working in that particular mode. Neat
Image can perform similar noise reduction on images captured or acquired by any other camera (or
scanner) working in any mode. To be able to do that Neat Image needs device noise profiles that
describe the noise characteristics of those devices. The software can build these profiles on the fly using
the Auto Profile function. Also, you can find ready-made noise profiles for many cameras and scanners in
the Profiles section of the Neat Image web page:

http://www.neatimage.com/mac/profiles.html

The next sections — Filtration process details, page 9, and Device noise profiles, page 20,— contain
detailed descriptions of the filtration and profiling processes. There are also examples of profiling and
filtration in the Neat Image web page:

http://www.neatimage.com/mac/examples.html
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5. Filtration process details

The Neat Image plug-in can be used in Photoshop to process any open image. This section describes the
key stages of using the Neat Image plug-in to process one image.

5.1. Stage I. Invoke the plug-in from Photoshop

In Photoshop, open and select an image that should be processed (it will be called ‘input image’
hereafter) and then invoke the Neat Image plug-in using the standard method:

®» Select the Filter > Neat Image > Reduce Noise.. menu item in Photoshop.

The Neat Image plug-in window will open and show the input image.

To scroll and pan the image
o press the spacebar and drag the image with the left mouse button.

To change the image zoom level

o use the mouse wheel when mouse is over the viewer;
o use the zoom control under the image viewer;
e use the Cmd+Plus, Cmd+Minus, Cmd+0 (zero), Cmd+Alt+0 (zero) keyboard shortcuts.

5.2. Stage Il. Prepare a device noise profile

To filter the input image, Neat Image needs to know the characteristics of noise produced by the image
acquisition device (digital camera, scanner, etc.) that the image comes from. The noise characteristics of
a device working in a certain mode are stored in a device noise profile.

There are several ways to get a device noise profile that suits the input image:

1. To build a new profile by analyzing the input image (or a specially prepared test image) using
the Auto Profile function;

2. To automatically select the most suitable device noise profile from a pre-built set of profiles
(when it is available) using the Auto Match function;

3. To manually select a suitable profile from a pre-built set of profiles using Load Profile.

The first option is often the easiest one provided the input image includes uniform featureless areas that
contain noise but no visible or important details.? Auto Profile will try to automatically find such image
areas and analyze them to build a noise profile. When the image does contain featureless areas, this
automatic way of preparing a noise profile is the most accurate and therefore recommended. If the input
image includes no such areas, another image with featureless areas can be used to build a profile.

The last two options are available once you have a pre-built reusable set of profiles. You can find some
free profile sets for different cameras and scanners in:

o Profiles section of the Neat Image web page:
http://www.neatimage.com/mac/profiles.html

o Device noise profiles section of the Neat Image community forum:
http://www.neatimage.net/forum/viewforum.php?f=5

o Other digital imaging forums and web pages from users of Neat Image.

If you cannot find a pre-built set of profiles for your camera or scanner, you can easily build such
profiles yourself. Moreover, please be aware that using profiles built by other people may produce less
than optimal results with your images because of possible slight differences in noise properties of
cameras (scanners) as well as due to different image processing workflows used. Therefore, we advise
to use profiles built by others only as a starting point to learn how to use Neat Image. To achieve better

! There is also a way to automatically process many images: please see the Using plug-in in actions and smart filters
section, page 18.

You can see some examples of featureless image areas in the Examples section, page 31.
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results consider building your own reusable profiles.

You can build a set of profiles for different device modes or just one profile to process one image. See
the Device noise profiles section, page 20, for detailed instructions on profiling.

Once you have a set of profiles for different modes of your imaging device, you can (automatically or
manually) select a profile that matches the input image. Or if you have just built a singe profile
specifically for the input image, then you can directly use the profile to process the image in the Stages
I1-1V below.

To build a new profile using the input image

Noise Filter Settings

= Make sure you use the Device Noise Profile tab: [ Device Noise Profile

» Click (the Auto Profile button).

Neat Image will find and highlight the image area selected by Auto Profile for main analysis. Neat
Image will then automatically analyze the noise in that area as well as in the whole image and will
build a new noise profile.

To build a profile, Neat Image is looking for a flat uniform featureless area in the input image. In
difficult cases, Neat Image may have trouble finding a uniform featureless area in the input image
and then the auto-selected area will contain some important image details. In such a case, move the
selection to an area that does not contain any image details (you can make a new selection or resize
the old one) and then click the same Auto Profile button again.

After the profile is built, check the profile Quality indicator in the Device Noise Profile box. A profile
built using a uniform and featureless image area will show a high value in this indicator. If the
profile quality is high (for example, higher than 75%) then you can be sure that the noise profile is
accurate. In this case, consider the noise profile ready and proceed to Stage Ill. Adjust filter
settings, page 11.

If the quality is not high, try to select another uniform image area and use Auto Profile Once again.
That may not help still, especially if the input image contains only a few featureless areas. In this
case, consider building a noise profile using an alternative image or special test image prepared
with the Calibration Target. Please see the Device noise profiles section, page 20, to learn how to
use the Calibration Target to build device noise profiles. You can also try to load some pre-built
profile using one of the methods described below.

To automatically select matching noise profile from a pre-built profile set

» Click (the Auto Match button).

The Auto Match function uses the EXIF data fields of the input image to automatically select and load
the device noise profile that matches the device mode of the image. The most matching profile is

selected from profiles stored in a special folder. By default, this folder is in your home folder™:
/Users/<username>/Documents/Neat Image for Photoshop/Profiles/

Auto Match will look for matching profiles in that folder as well as all its subfolders (where you can
save profiles and profile sets built by you or downloaded from the Internet).

After a profile is loaded by Auto Match, the degree of match between the current input image and
loaded noise profile is displayed in the Device Noise Profile box. Higher values mean better match,
leading to more accurate filtration.

To manually select a noise profile from a pre-built profile set

®» Click (the Load Profile button). Then select a profile in the Open Device Noise

1 You can check and adjust the location of that folder using the menu Tools > Preferences > Matching.
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Profile dialog.

or

®» Click 7 (the drop-down button) in the Device Noise Profile box to open the popup menu with all
available profiles and then select one of the available profiles.

Please note that you have either to build your own profiles or download some pre-built profiles and

place them to the Neat Image’s Profile folder to make this drop-down button and popup menu truly

work. By default, the Profile folder is located in your home folder™:
/Users/<username>/Documents/Neat Image for Photoshop/Profiles/

If you build or download some pre-built profiles, save them to that folder and Neat Image will show
those profiles in the popup menu to help you quickly re-open any of the profiles.

When manually selecting a profile for input image, use the profile file names and folder structure to
guide your search. See Preparing profile set for different device modes: Stage I1l. Structuring
profile set, page 28, for more information on profile set structuring.

To additionally fine-tune the loaded or matched profile

You may want to additionally fine-tune the profile loaded either automatically (using Auto Match) or
manually (using Load Profile).

®» Click (the Auto Fine-Tune button) to fine-tune the profile to the current input
image.

There is no need to select any area in the input image because Auto Fine-Tune automatically analyzes
the whole image.

Fine-tuning the profile to the current image usually makes the profile more accurate and better
reflecting the image’s noise properties.

Please note that you do not need to fine-tune a profile if you have built it using Auto Profile. Auto
Profile automatically applies fine-tuning so you do not need to repeat it.

Once you have loaded the profile that matches the input image or you have just built a new profile
specifically for the input image, you can proceed to process the image in the Stages I11-1V below.

5.3. Stage lll. Adjust filter settings

As soon as the noise profile is ready you can use the noise and sharpening filters. These filters have
several adjustable settings. The default settings usually produce good filtration results. You may want to
additionally vary the filter settings to achieve the filtration results that look best to your eyes.

Noise Filter Settings ’

® Make sure you use the Noise Filter Settings tab; 4’ _Device Noise Profile |5

5.3.1. Use preview when adjusting filter settings

The viewer in the Noise Filter Settings tab shows a part of the image processed by the noise and
sharpening filters. If you change any filter settin%s then the ?review is automatically updated (provided
the Preview button in the toolbar is depressed: ). You can zoom in and out, drag, scroll,
pan the image to see how the filtration affects different parts of the image. If you manually select an area
in the image then only the selected area will be processed for preview.

When the preview is ready (the preview area shows “Filtered™), you can click inside the preview image
area to temporarily switch back to the original for comparison.

1 . . ) .
You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders.
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5.3.2. Standard and Advanced modes

Neat Image has two sets of filter controls, they are available in the standard mode and Advanced mode
(you can select the mode using the Tools > Standard mode and Advanced Mode menu items). The Standard
mode provides a simple control set, recommended for beginners who just start using Neat Image. The
Advanced mode provides the most complete control set with maximum manual control over noise
profiling and filtration processes. The Advanced mode is recommended for power users. Adjusting filter
settings is described below separately for the Standard and Advanced mode. We recommend starting with
the part about the Standard mode and then proceeding to the part about the Advanced mode if you are
going to use the complete control set.

5.3.3. Adjust filter settings in Standard mode

There are two main filters in Neat Image: noise reduction filter and sharpening filter. These two filters
can be used together and each of them can be used independently. You can enable, disable and adjust
these filters using the guidelines in the subsections below.

Adjusting noise filter settings in Standard mode

If you work with a color image then two major image components can be distinguished: the luminance
and chrominance component. This distinction is very useful from the standpoint of noise reduction
because it allows processing luminance and chrominance information separately.

Some color images are represented in color spaces that enable direct separation of the luminance and
chrominance components (for example, Lab, YCrCb, etc.). Other

images (including RGB images that Neat Image takes as input) have Filter Settings

to be converted to another representation to enable separation of the
luminance and chrominance components. Neat Image applies an
internal color space conversion to achieve that. Once luminance and | . o @ @ ounts
chrominance components of the input image are separated, Neat _

Image can treat them individually. Neat Image provides separate Luminance === cox
luminance and chrominance settings in the noise filter (see the figure  chrominance =——————ef® 100%
on the right).

default -

Sharpening

In the Standard mode, the noise reduction applied to one image
Amount 8= 0%

component (either luminance or chrominance component) is
controlled by the corresponding noise reduction amount setting.

A noise reduction amount tells the filter how much of the detected noise should be reduced. For
example, if the noise reduction amount is set to 50% then all image elements that are considered (by the
filter) to be noise are reduced (made weaker) in half. The noise reduction amount value of 100% tells the
filter to remove the detected noise completely.

The default noise reduction amounts usually produce good filtration results provided the noise profile is

accurate’. By default, the noise filter removes 60% of detected noise in the luminance component of the
input image and 100% of noise in the chrominance component. Our experience shows that the default
noise reduction amounts usually provide a good balance between noise removal and preserving natural
(not over-processed) appearance of filtered images.

Decreasing the noise reduction amounts may have a positive effect if the input image contains some
natural noise. For example, when you filter images of asphalt, sand, or anything else that contains fine
natural noise-like features, it may be helpful to reduce amounts down to 30-50%.

Adjust noise reduction amounts? As human vision is not very
sensitive to variations of colors,
strong filtration in the
chrominance component does
not noticeably distort image, but

You can vary the noise reduction amount for both luminance and | efficiently removes color noise.

®» Use the Noise Reduction Amounts: Luminance and Chrominance
sliders.

1 Use the Quality and Match indicators in the Device Noise Profile box to estimate the accuracy of the profile. The
Quality indicator shows how accurate and complete is the noise analysis itself. The Match indicator shows how closely
this profile corresponds to the input image. Both indicators have to show high values for the noise reduction to be
accurate.

2 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter, set the
Sharpening: Amount to 0%.
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chrominance component of the input image. The higher a certain noise reduction amount, the more
of the detected noise is removed in the corresponding image component. Be careful, setting the
noise reduction amounts too high, especially in the luminance component, may lead to loss of fine
details and unnaturally looking (over-smooth, plastic-like) results. Too low amounts may be not
enough to sufficiently reduce the objectionable part of the noise. You have to balance the noise
reduction amounts (most importantly, the amount of noise reduction in the luminance component)
to get the result that looks best to your eyes.

Use preview

As you make changes in the noise filter parameters, check preview on different parts of the image to
get a better feeling for the prospective results of noise reduction.

If the noise filtration looks too strong try to decrease the noise reduction amounts. If the noise
filtration is not sufficient then increase the amounts.

Adjusting sharpening settings in Standard mode (optional)
The sharpening filter in Neat Image increases image sharpness without increasing the noise strength.

The sharpening filter is disabled (sharpening amount is set to 0%) by default. Increase the sharpening
amount to sharpen the image. Like with any sharpening method, you have to balance the sharpening
amount to avoid over-sharpening.

Use the preview when adjusting the sharpening settings. Filter Settings
_ |
Adjust sharpening amount e -

Moise Reduction Amounts

®» Use the Sharpening: Amount slider. _
Luminance =8= 60%

Specify how much sharpening should be applied to the input

image. Chrominance =e 100%
Sharpening
Use preview Amount A gx

As you make changes to the sharpening setting, check preview
on different parts of the image to get a better feeling for the results of sharpening.

As soon as you are happy with the preview results regarding both noise reduction and sharpening,
proceed to save the filter settings into a preset (see page 16), or directly to the Stage V. Apply filter,
page 17.

5.3.4. Adjust filter settings in Advanced mode

As said above, Neat Image has two sets of filter controls, that are available in the Standard mode and
Advanced mode (you can select the mode using the Tools > Standard mode and Advanced Mode menu items).
The standard mode described above provides a simple control set, recommended for beginners who just
start using Neat Image. The Advanced mode provides the most complete control set with maximum
manual control over noise profiling and filtration processes. The Advanced mode is recommended for
power users. If you want to use the Advanced mode then please read this sub-section.

As compared with the Standard mode, the Advanced mode offers a more extensive set of filter controls.
There are also two filters — noise reduction filter and sharpening filter — but these have more settings
now. Please follow the guidelines below to adjust both filters.

Adjusting noise filter settings in Advanced mode

In Advanced mode, the noise filter has separate settings for all frequency and channel components of the
input image. There are also pairs of noise level - noise reduction amount controls for each of these
image components. The meaning of each noise level - noise reduction amount pair is the following:

e anoise level control adjusts the threshold that determines which image elements are considered
noise in the corresponding image component and which elements are considered not noise;

1 You can skip this subsection when reading for the first time.
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e a noise reduction amount control determines how much reduction is applied to the image elements

identified as noise in the same image component.

In Advanced mode, you can adjust the noise levels as well as noise

Filter Settings

reduction amounts for each image component. The noise levels are @
adjusted relative to the noise levels of the current noise profile that P -
have been measured during profiling. PR —
For example, the noise level of the Y (luminance) channel could be High 38 e Qe 0%
measured in the noise profile at 8.55 units.® This number tells the [""’ =6=E :E:
noise filter which image elements should be considered noise and >
which — image details: the image elements that are weaker than 8.55 ; ‘5 =8=E :2:
units are considered noise and reduced by the noise filter; the image b Q P +0%
elements that are stronger than 8.55 units are considered details and : )
not reduced. MNoise Redl_.lcnon Amounts

High ﬁ% ':E’y 100%
If you do not change the default noise filter settings (Noise Levels: Y: Mid (] e}  100%
+0%) then noise reduction in the Y channel is completely determined = Lo — 100%
by the measured number from the noise profile (8.55 units). Y U = 0%
However, if you do adjust the filter setting for the v noise level then = €r @ ==} 100%
this adjustment is also taken into account. For example, if you setthe =~ & © =—————— 100
Noise Levels: Y control to +15% then what is considered by the noise [ verylowfreq ™ High quality

"1 Smooth edges E‘ High resalution

filter as the actual noise level is:
8.55 * (100% + 15%) => 9.83 units

With this adjustment, the image elements in the Y channel that are weaker than 9.83 units are considered
noise and reduced, and elements that are stronger than 9.83 units are preserved.

Thus, with a noise level - noise reduction amount pair of settings you can adjust what should be
considered noise in a component of the input image and how much of this noise should be reduced. You
have access to six such pairs — three for channel components (Y, Cr, Cb) and three for spatial frequency
components (High, Mid, Low) of the input image.

Because the noise level controls are relative to the device noise profile, the default filter settings usually

produce good results when the noise profile is accurate’. The noise level defaults are 0%, which means
the noise levels are completely determined by the noise profile. When you adjust the level controls, the
noise level estimations are raised or lowered accordingly. A noise level control can be in the range from
—100%, which means no image elements are considered noise, and therefore, no noise reduction is
applied in the corresponding image component; to +150%, which means noise reduction is applied to
the image elements that are weaker than 250% of the noise profile’s noise level.

Noise reduction amounts can be in the range from 0% (none of the detected noise is removed) to 100%
(all the detected noise is removed). By default, the noise filter removes 100% of detected noise in all but
the luminance () channel where only 60% of detected noise is removed.

Decreasing the noise reduction amounts can have a positive effect if the input image contains some

natural noise. For example, when you filter images of asphalt, sand, or anything else that contains fine
natural noise-like features, it may be helpful to reduce amounts down to 30-50%. Our experience shows
that these values generally provide a good balance between preserving image details and noise removal.

Adjust noise reduction amounts®

®» Use the Noise Reduction Amounts: High, Mid, Low; Y, Cr, Cb sliders.

You can vary the noise reduction amount for each
frequency and channel component of the input
image. The higher a certain noise reduction amount,
the more of the detected noise is removed in the

As human vision is not very sensitive to
variations of colors, strong filtration in the Cr
and Cb channels does not noticeably distort an
image, but efficiently removes color noise.

All measured noise levels are shown in the Profile Viewer (use the menu Profile > Profile Viewer to open it).

2 Use the Quality and Match indicators in the Device Noise Profile box to estimate the accuracy of the profile. The
Quality indicator shows how accurate and complete is the noise profile itself. The Match indicator shows how closely
this profile corresponds to the input image. Both indicators have to show high values for the noise reduction to be
accurate.

3 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter,
uncheck all channels in the Sharpening Settings box.
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corresponding image component. Be careful, setting the noise reduction amounts too high can lead
to unnaturally looking (over-smooth, plastic-like) results. Too low amounts may be not enough to
sufficiently remove the objectionable part of the noise. You have to balance the noise reduction
amounts (most importantly, the amount of noise reduction in the vy channel) to get the result that
looks best to your eyes.

If the input image has only fine (high frequency) noise then you can utilize only the high frequency
filter and switch off the filters for other frequencies by setting their amounts to 0%.

Adjust additional filter settings (optional)

® |f the input image contains strong low frequency noise (for example, a very coarse-grained color
splotches) then you may want to switch on the very low frequency filter (check the Very low freq
checkbox in the Filter Settings box).

®» Check the smooth edges checkbox to make edges and lines look smoother.

® Check the High quality checkbox to enable the higher-quality noise reduction filter. This will slightly
slow down processing but will deliver the most accurate results in return.

® Check the High resolution checkbox to enable the higher-resolution noise filter. This may be useful
when processing images with very fine details that should be better preserved by the filter.

Use preview

As you make changes to the noise filter parameters, check preview on different parts of the image to
get a better feeling for the results of noise reduction.

If the noise filtration looks too aggressive try to decrease the noise reduction amounts for
appropriate channels or frequency components. If the noise filtration is not sufficient then increase
the amounts.

Adjust noise levels (only when necessary)

Usually it is not necessary to change the noise levels if the noise profile is accurate. You only have
to adjust the noise levels if you see that some noise elements are not reduced even if you set the
noise reduction amounts to 100%. Such residual noise elements are usually caused by inaccurate
noise profile (providing inaccurate estimations of actual noise levels). This may be compensated by
adjusting (increasing) the noise levels in the filter settings.

®» Use the Noise Levels: High, Mid, Low; Y, Cr, Cb sliders.
The noise filter has access to three frequency components and three channel components of the

input image. The corresponding sliders adjust the estimated noise levels of these components.

The higher a certain noise level, the more image elements in the corresponding image component
are considered noise. Be careful, setting a noise level setting too high can lead to removal of
important image details. Setting a noise level setting too low can lead to incomplete filtration:
residual noise and compression artifacts can stay in the output image.

As arule, if the device noise profile has been built properly, it is not necessary to increase the noise
levels by more than 50%. If the input image contains strong surges of noise in the high frequency
range, it is recommended to increase the high frequency noise level up to +20 to 40%.

If the input image contains strong color noise, it is recommended to increase the Cr and Cb noise
levels to +30%. In some cases, it may be useful to increase these noise levels up to +100%.

If adjusting noise levels still does not help and some noise elements remain visible in the preview
and output image, probably the device noise profile is not good at all. Return to Stage I, page 9, and
rebuild the profile from scratch.

Adjusting sharpening settings in Advanced mode (optional)
The sharpening filter is designed to increase image sharpness without increasing the noise strength.

The default values of the sharpening settings should produce satisfactory results (when sharpening is
enabled for any of the channel components) but you are encouraged to vary the settings to find values
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that produce the desired level of sharpness. Zero sharpening amounts will not sharpen the image at all.
The non-zero sharpening amounts will apply sharpening of the specified strength. Use sharpening
controls for different frequency components to sharpen fine, medium or large image details. As with
any other sharpening method, you have to balance the amounts to avoid over-sharpening.

Use the preview when adjusting the sharpening settings.

Select color channels where sharpening should be applied

®» Use checkboxes in the Sharpening section. Sharpening
Usuall | h he lumi hannel Ov Ocr Oco # consenarive

sually you only want to sharpen the luminance channel - v. Hh 1] o oo

i mid 4 O 0%

Select sharpening mode o 1 O ”

®» Check the Conservative checkbox to enable more accurate
sharpening, which produces much less halo effect around sharpened image details.

Adjust sharpening amounts

®» Use the High, Mid and Low sliders in the Sharpening section.
Specify how much sharpening should be applied to each frequency component of the image.

The standard sharpening settings used by many graphic editors are 100% for high frequency and
0% for medium and low frequencies (used by default).

As soon as you are happy with the preview results regarding both noise reduction and sharpening,
proceed to save the filter settings into a preset (see the subsection below), or directly to the Stage V.
Apply filter, page 17.

5.3.5. Save filter settings into a preset (optional)

To save the current filter settings into a preset

» Click = (the save filter settings as preset.. button) in the Filter Settings box.

In the save Filter Preset As dialog box, specify the name of the file to save the preset. The filter
presets are stored in *.nfp files.

Saved filter preset includes the noise filter and sharpening settings. By re-opening a preset, you can
reproduce exactly the same filter settings later on. Also, you can exchange filter presets with other
users of Neat Image. Together, a device noise profile and a filter preset can be used to precisely
reproduce the filtration results.

To load a previously saved filter preset

®» Click '@ (the Load filter preset.. button) in the Filter Settings box. In the Load Filter Preset dialog box,
specify the name of the filter preset to be opened.

or

®» Click ™ (thedrop-down button) in the Filter Settings box to open the popup menu with all available
presets and then select one of them.

There are several pre-written filter presets in the following sub-folder® in your home folder:
/Users/<username>/Documents/Neat Image for Photoshop/Presets/

Please explore these presets to see what combinations and values of the noise and sharpening
filter’s settings can be used to solve typical tasks (names of the presets explain these tasks).

1 . . .
You can check and adjust the location of that folder using the menu Tools > Preferences > Folders > Preset folder.
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5.4. Stage IV. Adjust Action settings® (optional)

At this point in the workflow, the noise profile is ready, filter settings are adjusted and, therefore, the
filter is ready to be applied to the image. However, before applying the filter, you may want to adjust the
Action Setup settings accessible via the Action Setup button: |_Action Setup )

These settings specify which noise profile and filter preset should be used by the plug-in on startup
when you use the plug-in next time. For example, you can have Neat Image automatically build a new
noise profile using Auto Profile when you open the plug-in.

The following options are available for noise profiles:
Action Setup

® Use Current Profile
Neat Image will use the profile currently loaded/built in the
plug-in; =) Use Current Profile

E950 (150225; 2bpp; 800x1200; WI

Device Noise Profile

® Auto Match
Neat Image will use profile matching to find and load a
matching profile from the profile set on the disk;

() Auto Match
() Auto Profile

aAuto Fine-Tune

® Auto Profile Filter Preset
Neat Image will use Auto Profile to build a profile using the
. . . Use Current Preset
Input Image;
default

® Auto Fine-Tune
Neat Image will additionally apply Auto Fine-Tune to adapt (cancel ) €0k )
the loaded profile to the input image; this option is
available when you use either Use Current Profile Or Auto Match (Auto Profile applies Auto Fine-Tune
automatically);

The plug-in will always use the current filter settings as the default filter preset for the next run.

5.5. Stage V. Apply filter
To apply filter to the image

®» Click (the Apply button in the bottom of the plug-in window).

The plug-in window will be closed and filtration
will start. Processing may take some time (from Neat Image is a processor-intensive plug-in, so
seconds to minutes, depending on the speed of the processor's speed is the most important. On
your computer's processor and size of the Core 2 Duo 2GHz, processing a 10-megapixel
image). image takes about 10 seconds (Neat Image v6
plug-in for Photoshop). On a computer of typical
configuration, the processing time is linear with
respect to image size (in megapixels).

Then the filtered output image is displayed in
Photoshop and you can continue your Photoshop
workflow.

After filtration, the Neat Image plug-in will also automatically save the current settings such as
device noise profile, filter preset, Action Setup settings, which will enable re-applying the plug-in
(for example, using the cmd+F shortcut in Photoshop) with the same settings without re-doing the
stages I1-111. Also, you can open the plug-in manually and continue to work with the last used
parameters.

1 This subsection applies to Neat Image Pro plug-in only.
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6. Using plug-in in actions and smart filters:

6.1. Configuring Neat Image in actions and smart filters

The Neat Image plug-in can be used in Photoshop actionsand | Action Setup
smart filters along with the built-in Photoshop filters. The Device Noise Profile
plug-in has two parameters when used in an action or smart
filter: Profile and Preset. The Profile parameter tells Neat Image
which device noise profile should be used, the Preset parameter ESDIED 2 i bprtO xR0

specifies which filter preset should be used. O Auto Match
() Auto Profile

{®) Use Current Profile

When you record an action or configure a smart filter that

includes the Neat Image plug-in, you can select the source of
noise profile and filter preset that should be used by the plug-in. Filter Preset
To do that click \_Action Setup ] (the Action Setup button) in the

main plug-in window and then select the corresponding options
in the Action Setup window. You can later return and check which
options are selected in the current action or smart filter using that
window. (" Cancel ) E 0K 3

EAuro Fine-Tune

Use Current Preset

default

®» To specify how Neat Image should prepare noise profile(s) for the input image(s) processed by this
action or smart filter select one of the following options in the Device Noise Profile box:

e Use Current Profile - the plug-in will use a fixed noise profile that has been created or loaded
into plug-in at the time of action recording (configuring the smart
filter) and is currently available in the Device Noise Profile box in the
main plug-in window; the plug-in will record that noise profile into the
action or smart filter and will then always use it when the action is run or
smart filter is (re-)applied;

e Auto Profile - the plug-in will use Auto Profile to build new noise profile(s) for
the input image(s) when the action is run or smart filter is (re-)applied;
The input image(s) must contain enough flat featureless noise-only
areas suitable for noise analysis.

e Auto Match - the plug-in will use Auto Match to search and load the best matching
profile(s) for input image(s) from the profile set on the disk;2

e Auto Fine-Tune - the plug-in will additionally apply Auto Fine-Tune to adapt the loaded
profile(s) to the input image(s), to make the profile(s) more accurate;
this option is available when you select Use Current Profile or Auto Match.

®» The action or smart filter will use the filter preset created or loaded into plug-in at the time of action
recording (or configuring the smart filter). This filter preset will be recorded into the action or smart
filter and will then always be used when the action is run or smart filter is (re-)applied. When used
in an action, the Preset parameter contains the name of that preset. The preset name is also shown in
the Filter Settings box in the main plug-in window. You can change this preset using the controls in
the Filter Settings box and then the new or modified preset will be recorded into the action or smart
filter.

! Using the plug-in in Photoshop actions and smart filters is only supported in Neat Image Pro plug-in (Detailed feature
map, page 37). Also, smart filters are only supported by the most recent versions of Photoshop.

For this option to work, several noise profiles should be available on the hard drive. The profiles should be stored in
the folder specified in Preferences (you can check and modify its location using the menu Tools > Preferences >
Matching > Profile Matching). These can be profiles downloaded from the Neat Image online profile library or from
other sources. You can also use profiles built by you. The input images as well as profiles in the profile set should
contain the EXIF information to make profile-image matching possible. Most noise profiles available in the profile
library in Neat Image website do contain the EXIF data. New noise profiles built with the latest versions of Neat
Image plug-in will also contain the EXIF data (from the images used for profiling). Profiles built with some old

versions of Neat Image plug-in may not contain the EXIF data, so it may be useful to re-build them using the latest
version.
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When you complete the adjustments in the Action Setup window, click the Apply button to save them in
the action or smart filter that you currently record or configure.

6.2. Neat Image in action-based batch processing

The Neat Image plug-in for Photoshop can be used to process several images at a time using
Photoshop’s action-based batching facility.

To use this kind of batching you have to do the following:

1) Pick one image from the series of images that you want to process and manually apply Neat Image
filtration to this image to make sure you get the filtration results that you like. Then undo the
changes done to the image.

2) Start recording a new action in Photoshop
(if necessary consult Photoshop’s documentation to check how you can create, record and play
actions in your version of Photoshop).

3) While recording the action, repeat the step (1) and before applying the Neat Image plug-in click the
Action Setup button in Neat Image plug-in window and make sure the settings there correctly
describe the way you want Neat Image to prepare noise profile(s) and filter preset when the action
will be played. After configuring the Action Setup settings, click the Apply button in the Action Setup
window, and then click the Apply button in the main plug-in window.

4) Stop recording the action.
You will now have a ready for use action that includes Neat Image with configured parameters.

5) In Photoshop, go to the menu File > Automate > Batch. This will open the Batch window where you
can configure a new batch that will process your series of image.

6) Inthe set/ Action fields of the Batch window, select the action that you have just recorded.

7) Configure the rest of the Batch options according to the Photoshop user guide and start the batch
processing.

Photoshop’s Batch tool will then process your images using the action that you have prepared. Since
Neat Image is a part of that action, the Batch tool will apply Neat Image filtration to all images in the
batch.

Since it is possible that some of the images may not be automatically processed by Neat Image (or other
parts of the action) due to some errors, use the log options to save a log of the batch and then check
which image(s) failed. If they failed because Neat Image could not process them, you can find out why
that happened by manually running the action on one of those images. Make sure you run the action
with GUI/dialog enabled to make Neat Image open its main window and display the error messages that
will explain the problem to help you resolve it. After the problem is resolved, run the batch again using
the steps above.
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1.

7

Device noise profiles

A device noise profile (or noise profile, or simply profile) describes the properties of noise produced by
an imaging device (e.g., digital camera, scanner, etc.) working in a certain mode. Several noise profiles
corresponding to different modes of a device constitute a profile set. Neat Image can use profiles from
such a set to process images produced in any of the modes covered by the set.

You can find some pre-built noise profiles or build your own profiles for your camera or scanner. Learn
how to find, build and use device noise profiles in Neat Image in the subsections 7.1-7.4 below.

1. Getting ready-made noise profiles

You can find some free profile sets for different cameras and scanners in:

o Profiles section of the Neat Image web page:
http://www.neatimage.com/mac/profiles.html

¢ Device noise profiles section of the Neat Image community forum:
http://www.neatimage.net/forum/viewforum.php?f=5

o other digital imaging forums and web pages from users of Neat Image.

To use a profile set from one of these sources, download the archive with profiles and unzip all profiles
to the following folder® and/or its sub-folder(s) in your home folder:

/Users/<username>/Documents/Neat Image for Photoshop/Profiles/

After that you can load individual profiles from this set in Neat Image to process images produced in
device modes covered by this profile set.

Please be aware that using ready-made profiles built by other people may produce less than optimal
results with your images because of possible slight differences in noise properties of cameras (scanners)
as well as due to different imaging processing workflows used. Therefore, we advise to use ready-made
noise profiles built by others only as a starting point to learn how to use Neat Image. To achieve the best
results consider building your own profiles as explained in the subsections below.

2. Building profile for a device mode (standard

profiling procedure)

In this subsection, you will find out how to build a single noise profile for an image produced in a
certain shooting or scanning mode (such a profile can also be called “a profile for a certain mode of the
device”).

Building a new noise profile generally consists of three stages:

Stage I. Building a profile;
Stage Il. Documenting the profile;
Stage I11. Saving the profile.

The Stage I, building a profile, can be done with the use of a regular image (for example, the image that
you want to denoise or any other regular image) or with the use of the Calibration Target. These two
cases are described as two alternative versions of the Stage I:

Stage I. Case of building a profile using a regular image
Stage I. Case of building a profile using the Calibration Target

You may want to follow the case of building a noise profile using a regular image if you only need a
single-use profile to process selected input image. In this case, the input image (or an alternative regular
image from the same series; it should be produced by the same device working in the same mode)
should contain enough uniform featureless areas for noise analysis.

A uniform area (with minor variation in all channels of the image) may be overcast sky, clear sky
(without clouds and birds), or any other part of the image, where there are no visually perceptible details

1 . . ) .
You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders.
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(except the noise). Neat Image needs uniform featureless areas of around 128x128 pixels (minimum is
32x32 pixels). You can see some examples of uniform featureless image areas in the Examples section,
page 31.

If the input image does not contain such areas and you have no suitable alternative regular image that
contains such areas, you can prepare a special test image and follow the case of building a noise profile
using the Calibration Target. That is also recommended if you want to prepare a reusable noise profile
for a certain mode of your camera or scanner.

7.2.1. Stage |. Case of building a profile using a regular image
To build a noise profile using a regular image you have to take 2 steps:

Step 1. Preparing a regular image for noise analysis;
Step 2. Analyzing the image noise.

Step 1. Preparing aregular image for noise analysis

To analyze noise in a regular image, you can use the input image or an alternative regular image that
was produced by the same camera (or scanner) in the same or similar shooting (scanning) mode. Using
the input image usually produces most accurate noise profile that perfectly matches the noise properties
of this input image. However, if there are not enough flat featureless areas in the input image then you
have to use an alternative regular image.

Case of using the input image
In this case, simply open the input image in the plug-in.

To build a profile, work with this image in the step 2 below.

Case of using an alternative image

If there is no large enough uniform featureless areas in the input image, use an alternative image.
The alternative image is supposed to be produced by the same device working in the same or similar
mode. This can be just another image from the same series; the image should contain at least one
large enough uniform featureless area suitable for analysis.

Open an alternative image in Photoshop and then open this image in Neat Image plug-in for
analysis below.

Step 2. Analyzing image noise (profiling)

Analyzing noise is the main part of building a noise profile for an imaging device working in a certain
mode. The current version of Neat Image plug-in for Photoshop offers three ways of conducting the
noise analysis (profiling): automatic, semi-automatic and manual one. Using automatic profiling is
easier and therefore recommended for beginners. In difficult cases (for example if Neat Image cannot
automatically find a uniform featureless area in analyzed image), automatic profiling may not work well
or may produce less than perfect results. You can always override automatics and use semi-automatic or

1 .-
manual ™~ profiling.

Noise Filter Settings

®» Make sure you use the Device Noise Profile tab: [ Device Noise Profile

Case of automatic profiling

To analyze noise properties, Neat Image uses uniform image areas that contain noise but no visible
or important details. With automatic profiling, Neat Image tries to find one such area automatically
and then uses this area to analyze image noise.

®» Click (the Auto Profile button).

1 Manual profiling is available in Advanced mode only.
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Neat Image will automatically find image areas suitable for analysis and will analyze them
automatically, first the primary selected area and then the rest of the image. If the primary selected
area shown in viewer indeed contains no visible details then the resulting noise profile will be
accurate.

At this point the profile is ready. Please proceed to Stage I1. Documenting noise profile, page 25.

If the automatically selected image area does contain visible details then use the semi-automatic
profiling instead (see below).

Case of semi-automatic profiling

1) Find a uniform featureless image area

® Manually find and select an image area that contains no visible details.t

The area should be at least 32x32 pixels large. That is the minimum size; the recommended size is
128x128 pixels or more (you can resize the selection frame).

Scroll, pan, zoom the image to find a uniform image area and then select this area for analysis.

If you cannot find a uniform area in the input image, consider using an alternative regular image or
use the Calibration Target as explained in the next section (Stage I. Case of building a profile using
the Calibration Target, page 23).

2) Analyze selected image area

» Click (the Auto Profile button).

Neat Image will automatically analyze the selected image area and the rest of the image.

At this point the profile is ready. Please proceed to Stage Il. Documenting noise profile, page 25.

Case of manual profiling

1) Find a uniform featureless area

® Manually find and select an area that contains no visible details.

The area should be at least 32x32 pixels large. This is the minimum size; the recommended size is
128x128 pixels or more (you can resize the selection frame).

2) Analyze selected area

» Click (the Auto Profile button).

Neat Image will automatically analyze the selected area and build a noise profile.

3) Additionally manually fine-tune the profile

Fine-tuning uses additional flat featureless frame areas to make the noise profile more accurate.
You have to manually select and analyze several such areas one after another.

1) Find and select a uniform featureless area

® Scroll, pan, zoom the frame in the viewer in the Device Noise Profile tab to find a new uniform area.

The size of an area may be from 16x16 to 256x256 pixels. Using larger areas makes fine-tuning
more accurate. The selection edges will change their thickness according to the selection size.

1 . . . .
You can see some examples of uniform featureless image areas in the section Examples, page 31.
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2) Analyze selected area with Manual Fine-Tune

®» Click (the Manual Fine-Tune button) or select the Profile > Fine-Tune Using Selected Area menu
itemn.

The analysis results will be shown in the noise profile equalizer: the graphs of the equalizer will
change some of the values (see the picture on the right). You can

switch from one channel to another in the equalizer to better seea  +zo0%

specific channel’s graph, or select to show them all together.

The goal of manual fine-tuning is to fill the equalizer with T

measured values (shown as graph-color knots) in all points of the o
graphs. The previous steps (specifically, the Auto Profile function) %
may have already filled some of the values. Manual fine-tuning .

can further improve the analysis by filling out the still missing or e

interpolated values (shown as yellow knots) and/or making some o De[ee [»[x]
of already measured values more precise.

3) Repeat 1-2 above with other uniform areas of different brightness

To make a device noise profile more accurate, fine-tune it using several uniform image areas. Select
areas of different brightness for best results. Try to choose and analyze uniform areas to cover all or
most elements of the equalizer in all its color channels. The more elements of profile are analyzed,
the higher is the quality of the profile.

4) Complete fine-tuning using Auto Complete

®» Click [0] (the Auto Complete button) or select the Profile > Auto Complete menu item to automatically
complete the fine-tuning by adjusting the unmeasured values using interpolation based on the
measured data.

At this point the profile is ready. Proceed to Stage Il. Documenting noise profile, page 25.

7.2.2. Stage |. Case of building a profile using the Calibration
Target

The Calibration Target is specially designed to enable easy profiling of various imaging devices. It can
be used to build a single profile for a certain device mode or a set of profiles for different modes.

Follow the steps below to prepare a single profile using the Calibration Target.

Step 1. Preparing the Calibration Target

To use the Calibration Target, either use the menu Tools > Calibration Target and then the Display target..
button, or download the image of the Target from the Neat Image web page:
http://www.neatimage.com/mac/testtarget.html

There are two ways of using the Calibration Target: you can open it on the screen and take a shot (with
a digital or film camera, depending on your workflow) or you can print it out and shoot the hardcopy.

Shooting the Calibration Target off the screen is faster, especially with a digital camera. However, be
careful when shooting it off the screen of a CRT monitor because you may occasionally capture scan
bands. These bands may spoil a part of the shot. If you cannot avoid these bands, prepare a printed
version of the Calibration Target or shot it off an LCD monitor, which does not produce this effect.
Also, try to avoid glares when using a monitor with a glass or glossy screen.
Case of shooting the Calibration Target off the screen
1. Open the Calibration Target image on the screen.

2. Use the displayed Calibration Target in the Step 2 below.

Case of shooting the printed Calibration Target

1. Open the Calibration Target image in your image editor and print out the image on a sheet of white
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2.

matte paper; make sure the image fills the whole page;

Use the printed target in the Step 2 below.

Step 2. Preparing a shot or scan of the Calibration Target

Case of digital camera

1.

Use the displayed or printed Calibration Target to prepare a test shot for building a device noise
profile for your camera:

Set the camera to a certain shooting mode (I1SO level, etc.) you want to build a profile for;

Important: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus
image of the target;

Make sure the Calibration Target fills the whole frame and make a shot;

Open the resulting shot in Neat Image plug-in.

Case of flatbed scanner

1.

Use the printed Calibration Target to prepare a test scan for building a device noise profile for your
flatbed scanner:

Set the scanner to a certain scanning mode (resolution, light level, etc.) you want to build a profile
for;

If possible set the scanner slightly out of focus (an out of focus scan is preferred for profiling); a
possible way to achieve this is to raise the page over the scanner glass a bit;

Scan the printed Calibration Target;

Open the resulting scan in Neat Image plug-in.

Case of slide scanner

1.

Use the displayed or printed Calibration Target to prepare a test scan for building a device noise
profile for your film scanner:

Set the camera to a certain shooting mode (film type, exposure, etc.) you want to build a profile
for;

Important: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus
image of the target;

Make sure the Calibration Target fills the whole frame and make a shot;
Develop the slide and put it into the scanner;

Set the scanner to a certain scanning mode (resolution, light level, etc.) that you want to build a
profile for and scan the slide;

Open the resulting scan in Neat Image plug-in.

Step 3. Analyzing image noise

Having the shot or scan of the Calibration Target, Neat Image can build a noise profile automatically:

®» Use the Profile > Auto Profile with Calibration Target menu item.

After the analysis is completed, proceed to the Stage 11 below.

24
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7.2.3. Stage Il. Documenting noise profile

At this point of building the noise profile for your camera or scanner,  Dpevice Noise Profile
the noise analysis is done and all important noise characteristics are  [5]7
gathered in the profile. However, you may still have to manually

- R . . ES50 (I150225; 2bpp; 1600x 1200, WEL +
document the profile if Neat Image has not done this automatically.

With most images from digital cameras, Neat Image is able to Device Name and Mode:
automatically extract the crucial information about the camera mode = M<OM 20

from the EXIF data fields of the analyzed image and put this fsooh}*;zr:l_r;ggl-?s
information to the noise profile (you can see that in the Device Name | compressian: 2 bits/pixel
and Mode fields in the Device Noise Profile box. Exposure time: 0.50 sec

White balance: Default
If Neat Image has not automatically placed any information to the
Device Name and Mode fields after noise analysis, you can fill out
these fields manually. Quality:  77% Match: | 100%

®» Use the Device Name and Mode fields in the Device Noise Profile box. Here, you can specify the model
of the image acquisition device and describe the device mode, which can be something like the data
in the picture on the right.

About the Device name and mode notes

It is highly recommended to specify these details to keep record of devices, device modes, and
corresponding device noise profiles that you use.

The noise characteristics of any two devices can be extremely different. Even a single device in
different modes can produce significantly different noise. Therefore, it is always better to use
separate noise profiles for different devices and device modes to avoid inaccurate filtration and
artifacts. Commenting on the device name and device mode parameters helps you keep track of
them when you do manual profile matching, i.e., when you manually select a suitable profile to
process an image.

Automatic profile matching available in Neat Image uses the EXIF information from the image
files and profiles, not the Device Name and Mode fields, so filling out these fields may not be
necessary for automatic profile matching. However, filling out these fields is highly advisable
both for the clarity purposes and for the cases of EXIF-less input images (in such cases, you have
to manually select a suitable profile based on the Device Name and Mode fields).

See the Preparing profile set for different device modes section below to learn more about camera
and scanner parameters that may need to be documented in the Device Name and Mode fields.

7.2.4. Stage lll. Saving the noise profile

» Use (the save Device Noise Profile As.. button) in the Device Noise Profile boX.

In the Save Device Noise Profile As.. dialog box, select the file name to save the profile to. The default
name is based on the device name and device mode when these are available from the EXIF data
fields of the analyzed image. If the EXIF data are not available then the default profile name is
based on the name of analyzed image file. Use the suggested default or change the name of the file
to store the device noise profile. Device noise profiles are saved in *.dnp files.

File naming considerations

If you are going to re-use a device noise profile later on, select a good file name explaining the
device name and mode so that you could easily recognize this profile by its file name.
Alternatively, you can use special folder structuring to keep many device noise profiles arranged
according to their device modes.

See Preparing profile set for different device modes: Stage I11. Structuring profile set, page 28,
for additional information.

Saved noise profile includes complete noise analysis. Therefore, by re-opening the noise profile,
you can reproduce exactly the same conditions for image processing later on. Also, you can
exchange noise profiles with other Neat Image users.
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7.3. Preparing profile set for different device modes

Usually an imaging device can work in several different modes. Therefore, there should be several
device noise profiles, corresponding to each mode to enable accurate processing of arbitrary images
produced by this device. If a set of profiles covers all modes of the device then any image from this
device can be processed by using one of the profiles from the set.

This subsection explains how you can prepare a reusable set of profiles for a range of modes of an
imaging device.

As an owner of a certain imaging device you are in perfect position to prepare a profile set because you
have direct access to the device hardware. Moreover, using your own set of profiles makes noise
reduction more accurate because such profiles better reflect the specifics of the camera or scanner as
well as the workflow you use.

When building a set of profiles, please follow the guidelines below that will help you structure the
profile set in such a way as to make consequent reuse of the set easy for youl.

7.3.1. Stage I. Selecting device parameters for profile set

To build a set of profiles for particular camera or scanner, you have to identify different device
parameters that affect the noise characteristics and that you will take into account during profiling.
There may be many device parameters but not all of them influence image noise and those that do differ
by the strength of their influence. Naturally, you are only interested in those parameters that appreciably
affect noise. Different noise profiles should be prepared for different values of important parameters, so
you have to identify these parameters in the first place.

In the tables below, those parameters are described that appreciably affect noise characteristics (from

the most to the less important ones) for digital cameras and scanners:

Digital camera parameters in the order of decreasing importance

ISO rate 50, 100, 200, 400, etc.; Higher ISO rate produces more noise.

depends on a camera
Camera High, Normal, Low, etc.; In-camera noise reduction can reduce levels of
noise depends on a camera noise in photos (usually at expense of some
reduction details).
Sharpness Low, Normal, High, etc.; Internal sharpness adjustment of a camera makes
adjustment depends on a camera noise more intensive. Using no internal sharpness

adjustment produces least noise.

Compression

1:1 (or Uncompressed),

1:5 (or Fine), 1:10 (or Normal),
1:20 (or Basic), etc.

or

2 bits/pixel, 4 bits/pixel, etc.
depends on a camera

Strong JPEG compression typically produces
more JPEG artifacts and destroys image elements
including noise; weaker compression preserves
more image elements including noise created by
the image sensor. It is preferable to use the lowest
amount of compression for the best results.

Resolution 1:1 (original resolution, like Camera’s internal interpolation (both downsizing
1600x1200), 1:2 (downsized in | and upsizing, e.g., that of digital zoom) changes
camera, e.g., 800x600), 2:1 many characteristics of noise.

(digital zoom, 2x), etc.

White Sun, Cloudy, Incandescent, White balancing changes characteristics of noise

balance Fluorescent, etc.; (mainly of color noise) slightly.

depends on a camera

. ..and other people if you decide to share your results. Please do share because in this way you will help people with the
same camera or scanner model. You can submit a set of profiles to the Neat Image team to publish the set in the
profile library in www.neatimage.com (see Contacts, page 38) or just share them with other people directly.
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Exposure 1/16s, 1.0s, 16s; Longer exposures produce more hot-pixel noise;

also, some cameras switch on the automatic noise
reduction when exposure is longer than a certain

threshold — this may affect the noise levels.

Scanner / camera parameters in the order of decreasing importance

Film type | For example, Kodak Tmax Every film type produces specific grain pattern,
400, Kodak Tri-X Professional | which depend on film materials. Strength of the
320, Fuji Superia 200, etc. grain depends on ASA/ISO rate of the film.

Scanning | For example, 300 dpi, 3200 Higher scanner resolution emphasized film grain

resolution | dpi, 4000 dpi, etc. and makes it more evident in the scanner image.

Number Single pass, Multi-pass scanning can potentially produce less

of scan 2X pass, grainy images.

passes 4x pass, etc.

If two images were captured in the same or similar conditions (most of the above device mode
parameters are the same) then the noise of these two images should be very similar. If you have built a
device noise profile using one of these images, you can use this profile to filter both images with good
results. If the shooting or scanning conditions were different then the noise in two images could be
significantly different. In this case, cross-use of one noise profile is not recommended. Instead, two
different profiles should be built and used to filter these two images.

Based on these considerations and tables above, identify the device mode parameters of your camera or
scanner that (1) are important from the noise standpoint and (2) are changed in your imaging tasks. For
example, if you never change the sharpness adjustment of your digital camera then there is no need to
build profiles for different values of the sharpness adjustment parameter. On the other hand, if you do
shoot with different ISO rates then you have to build profiles for every 1SO rate you use. Some
parameters are less important (for example, the White Balance or Exposure) and you may simply
choose to ignore the difference in noise characteristics caused by such device mode parameters.

Identify and make a list of the device mode parameters that are important for your needs. For example,
you could include the ISO rate: 1SO 100, 200, 400; and JPEG compression level: HQ, SHQ. Then it is
straightforward to write down all combinations of the selected parameters:

JPEG HQ, I1SO 100
JPEG HQ, 1SO 200
JPEG HQ, 1SO 400
JPEG SHQ, 1SO 100
JPEG SHQ, 1SO 200
JPEG SHQ, 1SO 400

Now you have to prepare an individual profile for each combination from this list. Please proceed to the
Stage Il to build profiles for all combinations.

7.3.2. Stage Il. Building individual profiles

To build individual profiles for the profile set, you can either use the standard profiling procedure
described earlier, or employ a special Neat Image tool — the Batch Profiler.

Using standard profiling procedure

To build individual profiles using the standard profiling procedure, follow the guidelines of the

Building profile for a device mode section, page 20. Using those guidelines, build a new profile for

every combination of the device mode parameters as listed in Stage | above. The resulting set of noise

profiles (several *.DNP files on the disk) can be further structured as explained in the Stage I1l below.
Using Batch Profiler

The Batch Profiler is a dedicated tool that can automatically build several noise profiles using shots or
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scans of the Calibration Target (the Batch Profiler is not for regular images). To use this tool, you have to
prepare several shots (scans) of the Target and then analyze them all at once using the Batch Profiler.
1. Preparing set of images of the Calibration Target

To prepare shot or scan of the Calibration Target for every combination of device mode parameters,
please follow the two initial steps of Stage I. Case of building a profile using the Calibration Target:

Step 1. Preparing the Calibration Target, see page 23.
Step 2. Preparing a shot or scan of the Calibration Target, see page 24.

Do the Step 2 for every combination of device parameters in your list. Then place all resulting image
files to a new folder (and subfolders if necessary) on the hard drive, for example:
/Users/<username>/Target Images/*.JPG, *.TIFF
2. Preparing profiles
To prepare profiles using the images of the Calibration Target:
1. Select the Tools > Batch Profiler.. menu item to open the Batch Profiler window.

2. Inthe Batch Profiler window, specify the folder with images of the Calibration Target and the folder
where the Batch Profiler should save prepared device noise profiles.

3. Click the start button to initiate profiling process.
When profiling is finished, new noise profiles are saved in the selected target folder.
4. Click the close button to close the Batch Profiler window.

As the result, you have a set of noise profiles (several *.DNP files on the hard drive) that can be further
structured as explained in the Stage I11 below.

7.3.3. Stage lll. Structuring profile set

In the Stage I, you have prepared a set of profiles on the disk. You have assigned names to these
profiles that reflect the device modes they correspond to.

For example, profiles for Olympus C5050Z could be named like the following:

I/~ Olympus C5050Z I~ —disk folder
C5050Z (1SO100; JPEG HQ; SharpNormal; 2560x1696).dnp
C5050Z (1SO100; JPEG HQ; SharpNormal; 2560x1920).dnp Cifﬁgfra -
C5050Z (1SO100; JPEG SHQ; SharpNormal; 2560x1696).dnp
C5050Z (1SO100; JPEG SHQ; SharpNormal; 2560x1920).dnp 1SO ##
C5050Z (1S0200; JPEG HQ; SharpNormal; 2560x1696).dnp — ISO rate of camera mode
C5050Z (1SO200; JPEG HQ; SharpNormal; 2560x1920).dnp
C5050Z (1S0200; JPEG SHQ; SharpNormal; 2560x1696).dnp JPEG SHQ /JPEG HQ/
C5050Z (1SO200; JPEG SHQ; SharpNormal; 2560x1920).dnp TIFF
C5050Z (1SO400; JPEG HQ; SharpNormal; 2560x1696).dnp —file format and

ion level
C5050Z (1S0400; JPEG HQ; SharpNormal; 2560x1920).dnp compression feve

C5050Z (1SO400; JPEG SHQ; SharpNormal; 2560x1696).dnp
C5050Z (1SO400; JPEG SHQ; SharpNormal; 2560x1920).dnp
C5050Z (1SO100; TIFF; SharpNormal; 2288x1712).dnp

C5050Z (1SO100; TIFF; SharpNormal; 2560x1696).dnp X
C5050Z (1SO100; TIFF; SharpNormal; 2560x1920).dnp — image size
C5050Z (1SO200; TIFF; SharpNormal; 2288x1712).dnp
C5050Z (1SO200; TIFF; SharpNormal; 2560x1696).dnp
C5050Z (1SO200; TIFF; SharpNormal; 2560x1920).dnp
C5050Z (1SO400; TIFF; SharpNormal; 2288x1712).dnp
C5050Z (1SO400; TIFF; SharpNormal; 2560x1696).dnp
C5050Z (1SO400; TIFF; SharpNormal; 2560x1920).dnp

Sharp#tit
— sharpness adjustment

When the profiles are named like this, manual selection of a suitable profile is simple. You can check
the device mode of the input image in Photoshop or in Neat Image (using the info button in the bottom
of the image viewer in the main plug-in window) and then select a noise profile for this device mode
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from the list of profiles.

There is another way to select profile for an image, based on structuring the profile set using the disk
folders. For example, the above Olympus C5050Z profile set could be structured like this:

/=7 Olympus C5050Z
7 TIFF
I 2288x1712
ISO 100.dnp
I1SO 200.dnp
1SO 400.dnp
=7 2560x1696
1SO 100.dnp
1SO 200.dnp
ISO 400.dnp
I~ 2560x1920
1SO 100.dnp
1SO 200.dnp
1SO 400.dnp
r~ JPEG
7 HQ

7~ SHQ

=7 2560x1696
1SO 100.dnp
1SO 200.dnp
1SO 400.dnp

=7 2560x1920
ISO 100.dnp
1SO 200.dnp
1SO 400.dnp

=~ 2560x1696
I1SO 100.dnp
1SO 200.dnp
1SO 400.dnp

=7 2560x1920
1SO 100.dnp
I1SO 200.dnp
1SO 400.dnp

=7 — disk folder

Olympus C5050Z,

JPEG / TIFF,

HHHE X it

- the names of disk subfolders containing
device noise profiles for corresponding
device modes;

1SO ###.dnp
- device noise profiles;

Note that constant parameter (Sharpness
adjustment) is not reflected in the folder
structure. However, if there were profiles
with different values of these parameters

then additional subfolder should be added.

Parameters that can be disregarded, such
as exposure time, are not reflected in the
folder structure too.

In this case, the folder tree enables storing device noise profiles in a structured way, which helps to
select one profile from the set given the device mode of the input image.

Note that the automatic profile matching provided by Neat Image does work well in both cases: you can
keep the whole set of profiles as a flat list of files in one folder, or you can structure the files into
subfolders. This choice only affects the convenience of manual selection of profiles, while automatic

profile matching can handle both cases equally well.

If the automatic profile matching is not available (for example, if the images or profiles contain no EXIF
information or the available EXIF details are incomplete) then you have to select profiles manually.
Therefore, we recommend to structure profiles according to one of the methods above to make your

manual work easier.

7.3.4. Stage IV. Documenting profile set

Along with the text comments inside the device noise profiles and their file names, we advise to
document the whole profile set with a plain text file explaining the following points:

o Author of the profile set and profiling date
o Device name, firmware version
e Device modes that have been profiled in this set

e Device mode parameters that change within the profile set
¢ Device mode parameters that are constant for all profiles in the set
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o Post-processing applied (after receiving image from imaging device and before Neat Image)

An example of such a description is below:

Olympus C5050Z noise profiles
by John Smith, April 21, 2010

A set of profiles for Olympus C5050Z TIFF and JPEG files. The profiles were built using shots of the Calibration Target for
the following file formats and image sizes:

TIFF: 2048x1536 / 2288x1712 / 2560x1696 / 2560x1920
JPEG HQ / SHQ: 2560x1696 / 2560x1920

For each file format and image size above, shots with different 1ISO rates (100, 200 and 400) were made and used to build
profiles.

Default camera settings were used for Sharpness, Contrast, and Saturation. In-camera noise reduction was switched off. The
white balance was set to daylight.

No post processing was applied; the calibration target shots directly from the camera were opened in Neat Image to build
profiles.

Such kind of summary would help you figure out any set of profiles you prepared as well as let other
people understand your results if you decided to share your profiles.

7.4. Using noise profiles

When you have a set of profiles for your camera or scanner, you can directly use these profiles to
process images in Neat Image. Usually there is only one profile that is most suitable to process a given
input image. Therefore it is very important to select the right profile, which would provide the best
match between profile and image. Profiles in a set usually correspond to different modes of the imaging
device. To make a perfect match between a profile and image, the device mode of a profile should be the
same or very close to the device mode used to capture the image.

There are two ways to select a device noise profile that matches the input image:

e To automatically select the most suitable profile from a pre-built set of profiles using Auto Match
(see page 10 to learn how to use Auto Match);
e To manually select the most suitable profile from a pre-built profile set based on mode comments.

When you select and open a profile in either way, Neat Image shows the degree of match between the
profile and input image. This degree is shown by the match indicator in the Device Noise Profile box. The
match degree is calculated on the basis of the image and profile’s metadata (the EXIF data fields). If the
profile’s device mode is exactly the same as device mode used to capture the image then the match is
100%. There is always 100% match between an image and profile built using this very image. If the
device modes of a profile and image are very close then the match degree is close to 100%. The more
different the device modes of profile and image, the smaller the match degree. Use the match degree as
an indication of match accuracy. If the match degree is low then it is likely that building a new profile
(using the current input image or the Calibration Target shot in current device mode) would produce
better noise reduction results.

Obviously it is preferable to build a new noise profile for each new input image, because such a profile
would perfectly match the noise of that image. Nevertheless, any noise profile can, with some degree of
accuracy, be used to process other images captured by the same device working in the same or similar
mode. This is less accurate than building a profile for each image but saves time because building a new
quality profile can take more time than re-using a pre-built one. This is especially important if one
profile is re-used many times, for example to process a series of images produced in one device mode.
Also, it may not always be possible to build an accurate profile using input image when it contains no
flat featureless areas.

When using pre-built profiles, you may also want to pay attention to the Quality indicator in the Device
Noise Profile box. A properly-built and fine-tuned profile will show a high value in this indicator. If the
profile quality is high (for example, higher than 75%) then you can be sure that the profile is accurate.

Both Quality and Match indicators have to show high values for the noise reduction of the current input
image using the current noise profile to be accurate.
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8. Preferences

There are several preferences that adjust the behavior of the Neat Image plug-in.

Use the Tools > Preferences.. menu item to open the Preferences dialog box.

8.1. General preferences

Auto zoom to fit on image open

Check this option to make the image viewer automatically adjust zoom level to fit the image into the
window.

Show hints over interface controls

This option switches on/off the hints. The hints are displayed when the mouse pointer is placed over any
control in the Neat Image interface.

Enable multiprocessor support

Check this option to let Neat Image use all available cores and/or processors when running on a
multi-core / multi-processor computer.

8.2. Profiling preferences

Save noise samples in profiles

Enable this option to make Neat Image save a noise sample from the analyzed image area into device
noise profile (*.dnp file). This will increase the size of the *.dnp file but will also improve the
compatibility with the future versions of the software (Neat Image will be able to re-build the profile
using the saved noise sample).

Show warnings about selected image area

Enable this option to let Neat Image display warnings about selected image area during profiling. For
example, Neat Image may warn you about clipping or non-uniformity detected in the selected area, thus
helping you select a better area for profiling.

8.3. Matching preferences

8.3.1. Profile Matching

Use profile matching preferences to adjust the way Neat Image should conduct matching of noise profiles
to input image.

Look for noise profiles in the following folder

Neat Image will look for matching noise profiles in the specified folder. If you have several sub-folders
with profiles, select the topmost folder of all those subfolders to let Neat Image search in all of them.

By default, the folder used to store profiles (see the Folders > Profile folder Setting in the same Preferences
window) is used. You can use any other (sub-)folder for profile matching as well.

Matching parameters priorities

To automatically match profiles to the input image, Neat Image compares the device parameters of the
input image and candidate profiles from the folder specified by the above option. Different parameters
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8.

usually have to be matched with different priority. Using Matching parameters priorities controls, you can
select the priorities of such parameters as Input device, ISO rate, Compression, Resolution, Sharpness,
Exposure:

e Match — the parameter should match exactly;

e High — it is highly important that the parameter is very close or matches exactly;
e Low — it is preferable that the parameter is close or matches exactly;

e Ignore — the parameter is not important at all.

4. Folders preferences

Profile folder

Select the folder where Neat Image will look for device noise profiles. This should be the topmost folder
of all the (sub)folders with device noise profiles. Neat Image will display all profiles (stored in all
subfolders of the specified folder) in the popup menu in the Device noise profile panel of the plug-in
window and in other parts of Neat Image.

By default, the Profile folder is located in your home folder:
/Users/<username>/Documents/Neat Image for Photoshop/Profiles/

You can select another location to store and use your Neat Image profiles if you prefer.

Preset folder

32

Select the folder where Neat Image will look for filter presets. This should be the topmost folder of all
the (sub)folders with filter presets. Neat Image will display all presets (stored in all subfolders of the
specified folder) in the popup menu in the Filter Settings panel of the plug-in window and in other parts of
Neat Image.

By default, the Preset folder is located in your home folder:
/Users/<username>/Documents/Neat Image for Photoshop/Presets/

You can select another location to store and use your Neat Image presets if you prefer.
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9. Examples

9.1. Images to build a noise profile

The image below contains examples of areas that are “good” and “bad” from the standpoint of profiling.
Here, “good” image areas are highlighted in green, these should be at least 32x32 pixels large,
preferably more than 128x128 pixels; “bad” ones are highlighted in red. If the input image you have
does contain similar ‘good’ flat featureless noise-only areas as shown in the example then you can be
sure that automatic profiling will produce an accurate noise profile. However if there are no such flat
featureless areas in the input image, then automatic profiling will not work well with the image because
building a profile using an area with details produces an inaccurate profile that will then lead to very
inaccurate filtration. In such a case, you have to use either an alternative image with flat featureless
areas or to use the Calibration Target to produce test images with flat featureless areas.

Additional comments regarding the “good” and “bad” areas in this example are available on the next
page.
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These image areas are good to build device noise profiles, as they contain no visible details:

Examples of “bad” areas that contain visible details:

- NOT RECOMMENDED, because this area contains a
detail: corner — junction of wall and ceiling

— UNACCEPTABLE, because this area contains many details

— GOOD, because this area contains no important details

— GOOD, no important details (this area is from another image)

—NOT RECOMMENDED, because this area contains some
details: clouds (this area is from another image)
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9.2. Filtration results

Here are some examples of Neat Image performance.

Input Output

This is a small portion of a digital photo taken with a Nikon CoolPix 950 digital camera. The original
image contains easily visible noise. In this case, the source of noise is the camera's image sensor (CCD)
put in high 1SO mode.

Input Output

This image was also taken with a digital camera. Along with the strong high 1SO noise, there is an
image degradation caused by the JPEG compression. Even though Neat Image tries to do its best to
clean up such images, please avoid using strong JPEG compression!

See more filtration examples in the Neat Image web page:
http://www.neatimage.com/mac/examples.html
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10. Questions and answers

10.1. General questions

Q
A

>0 >» O

> O

What is the difference between Demo, Home and Pro plug-in?

The Demo plug-in is limited by size of image area that can be processed: it only processes a part of the
input image if the image is larger than 1024x1024 pixels. The Home plug-in is not limited by size of

image area but only processes 8-bit images. The Pro plug-in additionally supports 16-bit images. The
Pro plug-in (unlike Demo and Home) also supports Photoshop actions and smart filters (in the recent

versions of Photoshop). Please also see the Detailed feature map, page 37, for more details.

Should I uninstall Demo plug-in prior to installing Home / Pro plug-in?

That is not necessary. The Home / Pro plug-in can be installed over the Demo plug-in.

Should I uninstall the older version of Neat Image prior to installing a newer one?

Usually that is not necessary. A newer version can be installed over the older one, it will replace the old
one.

I think I have found a bug. How can | submit bug report?

Please use the online bug report form: http://www.neatimage.com/mac/brf.html
Please fill it out to let us know all the details necessary to reproduce the problem.

See more information about bugs in the Issues subsection, page 37, and about bug fixes in the
WhatsNew.txt file supplied with the software. Also see the history section in the Neat Image web page
for the most up to date information: http://www.neatimage.com/mac/history.html

10.2. Filtration-related questions

Q

Q

36

Why do | receive some crystal-like artifacts in the filtered image?

Presence of many residual noise elements is usually a consequence of using a poorly built noise profile
or a profile built for another device and/or device mode. Using a more accurate profile usually helps.
The crystal-like artifacts (usually these are the residual JPEG compression artifacts) look like thin lines
in the filtered image. They can be easily eliminated by increasing the high frequency noise level in the
filter settings.

Filtered image looks 'plastic'. Why?

The reason is that too much filtration was applied. Let Neat Image keep some noise to produce
natural-looking results. Adjust the noise reduction amounts; for example, reduce the noise reduction
amount in the luminance channel to 50%. Also, make sure the device noise profile does match the
image processed. Using an incorrectly chosen or poorly built profile can either produce plastic-looking
results or leave residual artifacts (see the previous question).

How to filter only the color noise (not the brightness noise)?

Set the value of the luminance (YY) noise reduction amount to 0%. This will disable filtration in the
luminance (brightness) image component.

Is processing via Neat Image best done before or after any other processing (i.e. tonal/color
correction)?

Such operations as tonal/color correction are quite conservative from the standpoint of noise, i.e., they
do not significantly change the noise characteristics of the image. Therefore, filtering before or after
makes little difference — as long as the noise profile is built and applied at the same stage of image
processing. For example, do not use a device noise profile built with an unprocessed (with the color
correction not yet applied) image to filter a processed image.

Some digital cameras apply some color correction internally. Other cameras allow access to
unprocessed RAW data. Neat Image is a generic filter, which can be applied in both cases. The only
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requirement is to use profile that matches the device mode of the input image.

On the other hand, image sharpening applied to a noisy image makes it much noisier. It is best to apply
Neat Image filtration before sharpening. However, the sharpening and noise filters of Neat Image can
be used together because the sharpening is applied AFTER noise filtration.

If you are not sure, try to use Neat Image as close to the source of the input image as possible.

11. Tips and tricks

11.1. Partial filtration

Some images contain both noisy and clean areas and it may be preferable to filter only noisy areas. This
can be manually done by combining two images — original and filtered one — using two layers in
Photoshop. For example, the following steps can be used:

Open the input image in your image editor;
Copy the input image in a new layer on top of the original image;

agrwdE

Apply Neat Image noise reduction to the top layer;
Adjust the transparency of the top layer so that noisy areas look fine;
Select and delete the areas of the top layer where filtration is not necessary or excessive (you

may want to use the eraser tool with adjustable transparency and shape).

12. Information

12.1. Issues and bugs

Please report any bugs or issues you encounter while working with Neat Image. Use the online bug
report form: http://www.neatimage.com/mac/brf.html

Your feedback will greatly help us improve the software and provide you with newer and better
versions of Neat Image.

12.2. Plans

The current version of Neat Image plug-in for Photoshop is going to be further improved in the
consequent updates. In particular, we are planning to add such functionality as:

e Component viewer for easier previewing and adjusting the filter settings
o Improved preview functions and variant selector

Also, we continue to work on the core noise reduction algorithms to improve the quality and speed of
noise reduction.

Please let us know if you have ideas that can make Neat Image better for you. Participate in discussions
in the Neat Image community forum, express your opinion, make suggestions, and ask questions. The
more people that ask for a feature the more likely that it will be implemented.

12.3. Detailed feature map

Features - Edition - -
Demo plug-in | Home plug-in Pro plug-in
Images 8 bits/channel (24-bit RGB, 8-bit Grayscale) +* + +
16 bits/channel (48-bit RGB, 16-bit Grayscale) - - +
Workflow Sypport for Photoshop actions and smart filters - - \ __+
File formats supported all formats supported by plug-in host
Device noise | Automatic and semi-automatic profiling +
profiles Automatic matching profiles to images A
Noise Channel-wise (Lum/Chr; Y, Cr, Ch) +
reduction Frequency-wise (High, Mid, Low, Very low) +
Smart Channel-wise (Y, Cr, Ch) +
sharpening | Frequency-wise (High, Mid, Low) +
Filter presets (reusable filter settings) +
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* - a limited part of the input image is processed if the image is larger than 1024x1024 pixels.

12.4. Contacts

We really appreciate your opinion of Neat Image. Please let us know what you think about the software.
Feel free to ask questions regarding Neat Image. To share your opinion or to receive support regarding
Neat Image, use any of the following means:

E-mails

info@neatimage.com — for general inquiries

photoshop-mac@neatimage.com — for inquiries regarding use of Neat Image for Photoshop /Mac

sales@neatimage.com — for inquiries regarding purchase of licenses for Neat Image

Community forum

Register in Neat Image community forum ( http://www.neatimage.net/forum/ ), and participate in
discussions on the use and development of Neat Image. Such topics are covered in the forum as:

¢ announcements of new and updated versions of the software;

questions about use of Neat Image;

examples of Neat Image performance with comments and suggestions;

feedback from Neat Image users: suggestions of new features and improvements;
contacts and general comments.

Web page

http://www.neatimage.com/mac/index.html

12.5. Legal information

Copyright
Neat Image © 1999-2010 by Neat Image team, ABSoft. All rights reserved.

License agreement

By downloading and/or using the Neat Image plug-in for Photoshop /Mac software (called “Neat Image” hereunder
in this agreement) you indicate that you accept this license agreement. If you are unable or unwilling to accept this
license agreement then you may not use Neat Image and must return and/or destroy all copies of Neat Image in your
possession.

You may
Use the Demo edition of Neat Image free of charge for non-commercial purposes only.
Copy and distribute the Demo edition of Neat Image.

Run the Home or Pro edition of Neat Image on one (or more, up to the number specified in your license) computer
(computers) at a time for commercial and other purposes provided you are a registered user and you have a valid
license for the corresponding edition of Neat Image.

You may not

Sublicense, rent, lease and sell any version or edition of Neat Image or any portion of it including the license data
without the explicit written permission from the Neat Image team, ABSoft.

Copy, share and distribute the Home and Pro edition of Neat Image or any portion of it including the license data
without the explicit written permission from the Neat Image team, ABSoft.

Decompile, disassemble, reverse engineer, modify, clone and emulate any version or edition of Neat Image or any
portion of it including the license data.

Use the Home or Pro edition of Neat Image if you are not registered user of the corresponding edition of Neat
Image.
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Term and termination

If you are a registered user of the Home or Pro edition of Neat Image and you have purchased a license for a certain
major version and edition of Neat Image then you may use this major version (including all minor updates of the
same major version) and edition of the software without time limitations provided you observe this license
agreement.

A license for a certain major version of the Home or Pro edition of Neat Image may be extended to a higher major
version. By decision of the Neat Image team, ABSoft, this extension may be automatic and free or may involve an
upgrade fee.

You may terminate this license agreement at any time by returning or destroying all copies of Neat Image in your
possession and notifying the Neat Image team.

This license agreement will terminate immediately if you infringe upon the Neat Image team, ABSoft’s copyrights
or breach this agreement. Copyright infringement or breaching this agreement may also result in criminal or civil
prosecution.

Disclaimer of warranty

The authors make no warranty or representation, either express or implied, with respect to this software, its quality,
accuracy, merchantability, or fitness for a particular purpose. This software is provided “as is", and you, its user,
assume the entire risk as to its quality and accuracy.

Distribution

The Demo edition of Neat Image may be distributed unmodified provided any charge is to cover distribution costs
only.

The Demo edition of Neat Image may be placed on magazine CDs, etc. as long as the Neat Image team is informed.

12.6. Registration
By becoming a registered user of Neat Image plug-in for Photoshop you will:

Encourage the authors to further develop and improve the software;

Get access to advanced functionality of Neat Image (see the Detailed feature map, page 37);
Be able to use Neat Image for commercial and other purposes;

Get free access to updates of the software with the same major version number (at least);
Enjoy reduced upgrade prices for new major versions of Neat Image or will get a free upgrade;
Receive the primary attention of Neat Image support group;

Receive the primary attention of Neat Image development group

(tell us what you want to see in the next version).

Message from the Neat Image team

By becoming a registered user you are helping us to further develop and improve the software.

Become a registered user and we will make Neat Image better for YOU!

12.7. Acknowledgments

Thank you to all the users who have contributed to Neat Image plug-in for Photoshop by proposing
improvements and new features.

Thanks to all the people who help us to find and fix bugs in Neat Image plug-in for Photoshop.
Thank you to all the users who stimulate the development of Neat Image by their word and deed.
Neat Image wouldn’t be neat without all of you!

Neat Image team, ABSoft
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13. Index

compatibility, 4

device noise profile, 9

batch profiler, 27

building, 20
automatic, 21
for a certain mode, 20
for different modes, 26
using calibration target, 23
using regular image, 21

ready-made, 20

examples, 33

features, 3, 37
filter preset, 8, 16
frequency, 15

high, 15, 36

low, 15

range, 5, 13, 15, 34
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very low, 15
license agreement, 38

noise
color, 15, 36
filter, 5, 13
high I1SO, 5, 35
level, 13, 14
reduction, 14
amount, 12, 13, 14

partial filtration, 37
plug-in, 5
profile matching, 10, 30

registration, 39

sharpening filter, 13, 15
system requirements, 4
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